Ubuntu16.04 QT5编译出现cannot find -lGL和collect2:error:ld

1、在Ubuntu16.04下安装QT5.6(64位)之后,新建工程,在编译的时候出现以下两个错误:
cannot find -lGL
collect2:error:ld returned 1 exit status

2、是由于系统缺少链接库,在终端执行下面两个命令就可以解决问题。

sudo apt-get install libgl1-mesa-dev
sudo apt-get install libglu1-mesa-dev freeglut3-dev

 



本文固定链接: http://20tc.com/ubuntu16-04-qt-waring.html | TC的博客

该日志由 TC 于2016年05月15日发表在 ubuntu 分类下, 你可以发表评论,并在保留原文地址及作者的情况下引用到你的网站或博客。
原创文章转载请注明: Ubuntu16.04 QT5编译出现cannot find -lGL和collect2:error:ld | TC的博客

Ubuntu16.04 QT5编译出现cannot find -lGL和collect2:error:ld:等您坐沙发呢!

发表评论


*

快捷键:Ctrl+Enter

无觅相关文章插件,快速提升流量